読者です 読者をやめる 読者になる 読者になる

Ruby1.9.3

Ruby を 1.9.2 から 1.9.3 にバージョンアップした時に、一カ所つまずいたことがあったのでメモ。

環境

問題

Ruby をインストールした後 gem コマンドを実行すると、以下のメッセージが表示された。

It seems your ruby installation is missing psych (for YAML output).
To eliminate this warning, please install libyaml and reinstall your ruby.

libyaml を入れてもう一度インストールしてね、だって。

インストール

% sudo apt-get install libyaml-dev

再び

再ビルド後 gem コマンドを実行し、例のメッセージが出ないことを確認。